Respondus LockDown Browser Update Required
JSU Home » Educational Technology & Support » Respondus LockDown Browser Update Required

The following outlines end-user changes needed on any computer where the Respondus LockDown Browser is used to take an exam in Blackboard.

  • Change needed for Windows and Mac OSX computers - All computers should be updated immediately with the latest version of the Respondus LockDown Browser.  This should be at least version 1.0.6.01 or later for Windows and at least version 1.0.6.00 or later for Mac OS.
    • To update, start the LockDown Browser application. Follow the prompts to download and install the latest version.
    • If there is no prompt to update, download the newest version and reinstall the LockDown Browser. (There is usually no need to uninstall, just be sure to choose the "Reinstall" option during installation.)

References:  JSU Download Site; Install Instructions for Students; Install Instructions for Faculty.